Re: Post Feedback and Feature Requests Here!

It would be really nice if the mobile player (Universal Playback) also would support the enableLooping=TRUE functionality as the flash version.

102

Re: Post Feedback and Feature Requests Here!

- If you have panoramic images (e.g. original image is 10.000 pixel wide and 3.000 pixel high) the thumbnail images are blurred. Please fix that.

- Positioning the caption doesnt always work well. Sometimes it is outside the browserwindow. Or somewhere else hidden.

- Showing some EXIF information (like shutter speed, aperture, iso, camera model, focal length) would be awesome. Maybe in a floating semi tranparent window. Activated by a new button in the button bar.

- And video support would be great!   ;)

All the best,
Jan

Last edited by JanR (2012-11-19 10:49:48)

Re: Post Feedback and Feature Requests Here!

@JanR

First of all, please ensure that you are using the latest version of SimpleViewer and svBuilder-Pro (v2.3.1). Please see the Upgrading SimpleViewer-Pro web page if necessary.

If you have panoramic images (e.g. original image is 10.000 pixel wide and 3.000 pixel high) the thumbnail images are blurred. Please fix that.

If you are referring to the actual thumbnail images that svBuilder-Pro produces, please let me know the dimensions of the thumbnails that you have set and, if possible, please upload one of your original images somewhere and post a download link to it so that I can try to replicate the problem and log a bug report if necessary.
If you are referring to the display of the images when viewing the gallery itself, please confirm whether this happens in the Flash Player, the Mobile Player or both. Also, please post a URL to a gallery which exhibits this thumbnail blurring so that I can take a look. Thank you.

Positioning the caption doesnt always work well. Sometimes it is outside the browserwindow. Or somewhere else hidden.

This can happen when using a Fixed Layout and the specified values are greater than the size of the user's browser window.
If not using a Fixed Layout, then try setting floatCaption="FALSE". This will force SimpleViewer to count the caption height in stage layouts.

Showing some EXIF information (like shutter speed, aperture, iso, camera model, focal length) would be awesome. Maybe in a floating semi tranparent window. Activated by a new button in the button bar.

And video support would be great!

Thank you for the suggestions.

Steven Speirs
SimpleViewer Support Team

104

Re: Post Feedback and Feature Requests Here!

First of all, please ensure that you are using the latest version of SimpleViewer and svBuilder-Pro (v2.3.1).

Oh yes, I am a new customer and downloaded/installed everything just 2 days ago.

Also, please post a URL to a gallery which exhibits this thumbnail blurring

Okay, check out this link: http://photo.janriggert.com/galleries/california
You should easily spot some blurred thumbnails on the first 2 thumb-pages.

Thank you for the suggestions.

Thanks for the fast reply!

Cheers!

Re: Post Feedback and Feature Requests Here!

Your thumbnails are of different dimensions to each other and to the size at which they are being displayed.
For example, one thumbnail is 100 x 67, another thumbnail is 100 x 75 and all are being displayed at the default dimensions of 75 x 75.
If all the thumbnails were of a uniform size and displayed at their actual size (using the thumbWidth and thumbHeight configuration options), then all should hopefully be fine.
I do not know how your gallery was originally created but I suspect it may have been a while ago as your gallery's XML file includes the imagePath and thumbPath configuration options which were deprecated in SimpleViewer v2.1.2.
Try recreating your gallery from scratch using svBuilder-Pro v2.3.1 to ensure that the thumbnails are all the same size and displayed at the correct dimensions.

Steven Speirs
SimpleViewer Support Team

106

Re: Post Feedback and Feature Requests Here!

The gallery was created within LR4 with the PPG SimpleViewer Pro module at the default settings. And I guess at this stage the thumbs have been created.
I then export the gallery to a folder and open that gallery with the svBuilder-Pro to edit the layout.
The resize image button is unchecked, as I dont want to reduce the image quality with another open/save action.

But I will keep a closer look at those settings and experiement around. Thanks for pointing me into the right direction.

/Jan

Last edited by JanR (2012-11-20 13:16:15)

Re: Post Feedback and Feature Requests Here!

I am currently using the Pro version, 2.3.1, and I have a suggestion for the sorting option.

Could it be possible to add a "Sort By Caption" option ? I would like to manually add my captions, and then hit "Sort By Caption", instead of sorting everything manually. The actual "Sort by File Name / Date" are no use for me, and I don't want to rename the file name, as it is used for other purposes.

Thx.

Re: Post Feedback and Feature Requests Here!

I am a new SimpleViewer-Pro user - great tool, I love the simplicity and flexibility, it all adds up to a lot of power.

Just wanted to post some feedback after a day or so troubleshooting an IE10 issue - gallery wouldn't run properly: images loaded but very glitchy, freezing and unfreezing. The problem went away when I disabled "Free Download Manager" extension in IE10 (intercepts download actions). I use FDM a lot, but seems to be causing a problem here. Would rather have SimpleViewer running properly.

So if you are getting glitchy performance in IE10, maybe you have FDM installed also...

Re: Post Feedback and Feature Requests Here!

@atomdocs

I have installed Free Download Manager in IE10 and I do not see a difference in the performance of SimpleViewer galleries (either Flash Player or Mobile Player galleries) with FDM enabled or disabled.
Is there a specific gallery that you are having trouble with and that I can view to try to see the problem myself (and do you see this problem in Flash Player galleries, Mobile Player galleries or both)?
Perhaps you have a gallery which preloads all images (imagePreloading="ALL") and FDM is generating download links to every image and file in your gallery. If so, try changing the value for the imagePreloading configuration option.

Steven Speirs
SimpleViewer Support Team

Re: Post Feedback and Feature Requests Here!

Hi Steven - thanks for taking a look. I just re-enabled FDM in IE and the problem came back, but I'm not a pro tester or coder, so I appreciate I might be missing something.

Just some more background - I also tried disabling Flash in IE and forcing the mobile viewer: all ok. So I did a full uninstall and reinstall of Flash: did not fix it, which is why I started switching extensions off and FDM made a difference, at least on my system (Win7 64).

Here is the gallery: http://www.atomdocs.com/football-heroes/

And here are my settings: http://www.atomdocs.com/sv/

As you will see, only 3 images in the gallery (NextGEN).

I also tested the page against the W3C page that you indicate elsewhere. There are 2 errors, but they are part of the WP code.

Thanks, Tom.

Re: Post Feedback and Feature Requests Here!

I uninstalled and reinstalled FDM: works fine now :) Thanks Steven. My apologies to FDM!

Re: Post Feedback and Feature Requests Here!

That's great. Thank you for posting back to let me know.

Steven Speirs
SimpleViewer Support Team

113

Re: Post Feedback and Feature Requests Here!

Please allow an option for thumbnails to NOT be cropped.


(FYI I'm Not subscribing to this topic so if you want me to see your reply you can reply at my thread at http://www.simpleviewer.net/forum/viewt … 004#p50004 )

Re: Post Feedback and Feature Requests Here!

I'm very new to simpleviewer  :(

I'm glad you have this sticky in place, it has helped me a great deal and saved so much time and stress!

just need to figure out how to make it load little faster!

thanks admin !

http://vividdreams.ca

Re: Post Feedback and Feature Requests Here!

@VividDreamsPhotography

just need to figure out how to make it load little faster!

Make sure that the images in your gallery are not too large (the larger they are, the longer they will take to load).
Images with file sizes of approximately 150KB are likely to be suitable for web gallery use (for most users) without sacrificing too much quality.

Also, you might like to take a look at the imagePreloading configuration option which determines how images are preloaded in a gallery. Descriptions of all the possible values for the imagePreloading configuration option can be found in the Main Image section of the Config Options page.

Steven Speirs
SimpleViewer Support Team

Re: Post Feedback and Feature Requests Here!

Thanks for the great software (svBuilder Pro) and the WebGallery for LR.
Is it not possible to add a caption automatically in svBuilder Pro with the IPTC and Exif data saved in the image like it is possible in the LR web gallery? That would make (my) life easier.
Are you planning a possibility to include also video embedding (like a Vimeo embed code) codes in the svBuilderPro?
Thanks Anna

Last edited by AthenaRot (2013-12-17 13:00:30)

Re: Post Feedback and Feature Requests Here!

Would be nice to have an option for overlays that show where in the gallery you are if there are no thumbnails.
Like those circles at the bottom:

http://abload.de/image.php?img=erlenhof … 4tkuwl.png

Re: Post Feedback and Feature Requests Here!

Hello,
I have three requests for features, you may can build in:

First: Is there a possibility to influence the content, shown at screenshots taken? So I would like to have the option to give a black screen or a logo or copyrightinformation or even the shown picture with a watermark, if someone makes a screenshot from it.

Second: It may could be nice to have something like comments to the pictures, shown below the gallery.

Third: Is there a better way to embed the gallery into a joomla-website, than to copy and paste the code into a report? Maybe you can make something like a plugin or module.

It would be really nice, if you can do some of this  :D
Tanks!

Re: Post Feedback and Feature Requests Here!

@Ulthwe

(1) There is no way to prevent a screenshot from being taken or to intercept a screenshot to add or change its content.
Perhaps the best course of action would be to watermark your images using the Watermark configuration options.

(2) SimpleViewer-Pro already supports individual captions for each image (which can be entered on svBuilder-Pro's 'Images' tab). You can position the captions below the main image by setting captionPosition="BOTTOM" (in svBuilder-Pro's 'Customize -> Caption' section) or by using a Fixed Layout. You can format captions using the available Caption configuration options and HTML formatting (for example, to create multi-line captions).
If you want the captions to be displayed below the gallery itself (not just below the main image within the gallery), then you can extract the caption from the currently displayed main image using the SimpleViewer-Pro API and display it in a container below the gallery using JavaScript.

(3) There is currently no SimpleViewer plugin for Joomla (but thank you for the suggestion). Perhaps the best way to embed a SimpleViewer gallery in Joomla would be to use the baseURL method. Essentially, this involves uploading your complete gallery folder to your web server (a single FTP action) and then pasting a single chunk of embedding code into your page, making sure that the two paths in the embedding code (the path to the 'simpleviewer.js' file and the baseURL itself) are correct.

Steven Speirs
SimpleViewer Support Team

Re: Post Feedback and Feature Requests Here!

If I understand correctly, in SV 1.9 there was an option to have the caption above the thumbnails and below the main image (which is what we want) without having to use a fixed layout. This feature was removed in SV 2. Could this be reintroduced? I have seen a number of requests for this elsewhere in the forum.

Re: Post Feedback and Feature Requests Here!

I've been a long time user of SVBuilder, primarily to create slide shows for real estate. We have added Video to our service and I don't have a great way of linking a YouTube video from the slide show. I've been using one of the slides as a vehicle to get to YouTube, but if I were able to add an icon to the main screen, it would be great. And if it worked on mobile devices, even better.

Re: Post Feedback and Feature Requests Here!

@steve.leach

Thank you for the suggestion.
You could maybe overlay an icon of your own on top of the gallery using HTML and CSS.
For example, try adding the following code to the <body> section of a sample gallery's 'index.html' page:

<div id="overlay" style="position: absolute; top: 10px; left: 10px; z-index: 9999;">
    <a href="http://www.example.com/">Link Text</a>
</div>

(You could change the text within the <a></a> tags for an image or icon if you like.)
In order for this to work, you will need to make your gallery's background transparent. Please see this FAQ for details:
How do I give SimpleViewer a transparent background?

Steven Speirs
SimpleViewer Support Team

123

Re: Post Feedback and Feature Requests Here!

Hello.
In section "Save Gallery" add checkbox nocache (embedding code with flashvar as default for opening galleries)
or always read a file gallery.xml from server - it is very small file.
Thanks.

Re: Post Feedback and Feature Requests Here!

@so

Thank you for your suggestion.

For anyone reading this and wanting to ensure that SimpleViewer always fetches the gallery's XML from the web server (rather than using a browser's cached version), then please see this forum thread.

Steven Speirs
SimpleViewer Support Team

Re: Post Feedback and Feature Requests Here!

Would be nice if there was a click to zoom option; something that allows the user to view a larger version of the image in slideshow.

Pro Version. v2.1.3
Mac OSX 10.6.8