Topic: "Flickr user not found" error

Hello,

I installed SimpleViewer in 2016, just a few months ago well after Flickr changed its security stuff. I just now noticed that I am getting this error on my portfolio website and none of the simpleviewer galleries will connect to flickr. I checked my flickr permissions to make sure they were set correctly, and they are, and am looking for help to correct this issue so my portfolio is working again. thanks!

Re: "Flickr user not found" error

It looks like the problem may be due to Flickr changing the 'crossdomain.xml' files on their servers (preventing online Flash applications from accessing Flickr API data) and is something that only Flickr can solve.

Please see this forum post for more information.

Unfortunately, SimpleViewer v1 does not feature a Mobile Player which you could use as a temporary workaround. (The Mobile Player was introduced in SimpleViewer v2.1.0.)

The only two options would be to either rebuild your galleries using local images (stored on your own web server) or wait for Flickr to fix the problem.

However, I might be overlooking something on the Flickr site but I see no official word of the change they seem to have made and no news on when the problem might be resolved.

Steven Speirs
SimpleViewer Support Team

Re: "Flickr user not found" error

Hi,

Thank you for the information, this gives me alternatives although not ideal. Makes me want to complain to Flickr about this change which overrides my own choice in how I want to share my own images, and I pay for a pro user license. They need to give users the option. I also contacted tech support at Flickr to see if I could get any suggestions from their team.
Thanks for your help!

Last edited by paintbetty (2016-09-19 15:02:33)

Re: "Flickr user not found" error

i just checked and see that I am using simpleviewer 2.3.2 - how do I set up the mobile player?

Re: "Flickr user not found" error

All you need to do to force a SimpleViewer gallery to use the Mobile Player instead of the Flash Player (regardless of whether or not Adobe Flash Player is installed and enabled in the user's browser) is to set the useFlash Embed Code Parameter in your gallery's embedding code to 'false'.
For example, just change:

simpleviewer.load("sv-container", "800", "600", "transparent", true);

... to:

simpleviewer.load("sv-container", "800", "600", "transparent", false);

For reference, configuration options supported by the Mobile Player can be found here.

Please also see this FAQ regarding the Mobile Player.
The mobile player layout does not match the Flash player layout. Why not?

Steven Speirs
SimpleViewer Support Team